Configurar EtherChannel
Configurar EtherChannel

Configurar EtherChannel

Diretrizes de configuração

Agora que você sabe o que é EtherChannel, este tópico explica como configurá-lo. As seguintes diretrizes e restrições são úteis para configurar o EtherChannel:

  • Suporte EtherChannel – Todas as interfaces Ethernet devem suportar EtherChannel sem a exigência de que as interfaces sejam fisicamente contíguas.
  • Velocidade e duplex – Configure todas as interfaces em um EtherChannel para operar na mesma velocidade e no mesmo modo duplex.
  • Correspondência de VLAN – Todas as interfaces no pacote EtherChannel devem ser atribuídas à mesma VLAN ou ser configuradas como um tronco (mostrado na figura).
  • Intervalo de VLANs – Um EtherChannel suporta o mesmo intervalo permitido de VLANs em todas as interfaces em um EtherChannel de entroncamento. Se o intervalo permitido de VLANs não for o mesmo, as interfaces não formam um EtherChannel, mesmo quando são definidas para o modo auto ou deseable.

A figura mostra uma configuração que permitiria a formação de um EtherChannel entre S1 e S2.

EtherChannel de configuração

Um EtherChannel é formado quando as definições de configuração correspondem em ambos os switches.

Na próxima figura, as portas S1 são configuradas como half duplex. Portanto, um EtherChannel não se formará entre S1 e S2.

Diretrizes de configuração EtherChannel

Um EtherChannel não é formado quando as configurações são diferentes em cada switch.

Se essas configurações precisarem ser alteradas, defina-as no modo de configuração da interface do canal de porta. Qualquer configuração aplicada à interface do canal de porta também afeta as interfaces individuais. No entanto, as configurações aplicadas às interfaces individuais não afetam a interface do canal de porta. Portanto, fazer alterações na configuração de uma interface que faz parte de um link EtherChannel pode causar problemas de compatibilidade de interface.

O canal da porta pode ser configurado no modo de acesso, modo de tronco (mais comum) ou em uma porta roteada.

Exemplo de configuração LACP

EtherChannel é desabilitado por padrão e deve ser configurado. A topologia na figura será usada para demonstrar um exemplo de configuração EtherChannel usando LACP.

Exemplo de configuração LACP

A configuração do EtherChannel com LACP requer as três etapas a seguir:

Etapa 1. Especifique as interfaces que compõem o grupo EtherChannel usando o comando do modo de configuração interface range interface global. A palavra-chave range permite selecionar várias interfaces e configurá-las todas juntas.

Etapa 2. Crie a interface de canal de porta com o comando channel-group identifier mode active no modo de configuração de faixa de interface. O identificador especifica um número de grupo de canais. As palavras-chave ativas do modo identificam isso como uma configuração EtherChannel do LACP.

Etapa 3. Para alterar as configurações da Camada 2 na interface do canal de porta, entre no modo de configuração da interface de canal de porta usando o comando interface port-channel, seguido pelo identificador de interface. No exemplo, S1 é configurado com um EtherChannel LACP. O canal de porta é configurado como uma interface de tronco com as VLANs permitidas especificadas.

S1(config)# interface range FastEthernet 0/1 - 2
S1(config-if-range)# channel-group 1 mode active
Creating a port-channel interface Port-channel 1
S1(config-if-range)# exit
S1(config-if)# interface port-channel 1
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk allowed vlan 1,2,20

Verificador de sintaxe – Configurar EtherChannel

Configure o EtherChannel para S2 com base nos requisitos especificados

Exemplo de configuração de EtherChannel
  • Entre no modo de intervalo da interface para FastEthernet0 / 1 e FastEthernet0 / 2. Use fa 0/1 – 2 como designação de interface.
S1(config)#interface range fa 0/1 - 2
  • Use a ajuda sensível ao contexto (?) Para exibir as opções para o comando channel-group.
S1(config-if-range)#channel-group ?
<1-6> Channel group number
  • Selecione o grupo de canais 1 e exiba a próxima opção.
S1(config-if-range)#channel-group 1 ?
mode Etherchannel Mode of the interface
  • Insira a palavra-chave do modo e exiba o próximo conjunto de opções.
S1(config-if-range)#channel-group 1 mode ?
active Enable LACP unconditionally 
auto Enable PAgP only if a PAgP device is detected 
desirable Enable PAgP unconditionally 
on Enable Etherchannel only 
passive Enable LACP only if a LACP device is detected
  • Configure o channel-group para usar o LACP incondicionalmente.
S1(config-if-range)#channel-group 1 mode active
\*Mar 21 00:02:28.184: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state 
to down 
\*Mar 21 00:02:28.193: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state 
to down 
\*Mar 21 00:02:36.179: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state 
to up 
\*Mar 21 00:02:36.674: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state 
to up 
S1(config-if-range)# 
\*Mar 21 00:04:31.170: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state 
to down 
\*Mar 21 00:04:31.186: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state 
to down 
\*Mar 21 00:04:33.116: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state 
to up 
\*Mar 21 00:04:34.114: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up 
\*Mar 21 00:04:35.037: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state 
to up 
\*Mar 21 00:04:35.121: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to 
up

Defina as configurações de switchport para o canal de porta que foi criado:

  • Entrar no modo de configuração da interface para o canal de porta 1
  • Configure o canal de porta 1 como um tronco
  • Permita que VLANS 1,2,20 cruze o link de tronco. Insira as VLANs conforme mostrado sem espaços.
S1(config-if-range)#interface port-channel 1
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk allowed vlan 1,2,20

Packet Tracer – Configurar EtherChannel

Três interruptores acabam de ser instalados. Existem uplinks redundantes entre os switches. Conforme configurado, apenas um desses links pode ser usado; caso contrário, um loop de ponte pode ocorrer. No entanto, usar apenas um link utiliza apenas metade da largura de banda disponível. O EtherChannel permite que até oito links redundantes sejam agrupados em um link lógico. Neste laboratório, você configurará o Port Aggregation Protocol (PAgP), um protocolo Cisco EtherChannel e o Link Aggregation Control Protocol (LACP), uma versão padrão aberta IEEE 802.3ad do EtherChannel.

[button url=”https://www.ccna.network/wp-content/uploads/2021/03/6.2.4-pt.zip” target=”self” style=”default” background=”#2fa614″ color=”#FFFFFF” size=”3″ wide=”no” center=”yes” radius=”auto” icon=”” icon_color=”#FFFFFF” text_shadow=”none” desc=”” download=”” onclick=”” rel=”” title=”” id=”” class=””]BAIXE AQUI[/button]

Pronto para ir! Continue visitando nosso blog do curso de networking, confira todo o conteúdo do CCNA 3 aqui; e você encontrará mais ferramentas e conceitos que o tornarão um profissional de rede.

  1. Bom dia ! tudo bem com vcs? Desejo que sim . Meu nome é Luciano Lima tenho 48 anos ,ingressei no curso de redes pela “Universidade de São Paulo” modalidade EAD, vocês tem sido de uma ajuda “Monstro” p mim , visto que curso como dito anteriormente na modalidade a distância , e já não sou tão jovem , e também por ter muitas responsabilidades familiares , trabalho tempo integral estudo a noite e também cuido de minha filha de 7 meses de idade.
    Tem sido um grande desafio para mim , mas com a ajuda de vcs e principalmente com ajuda de Deus espero chegar lá e mudar minha história de vida. muito obrigado!

O seu endereço de email não será publicado. Campos obrigatórios marcados com *

CCNA: Introdução às RedesCurso