Configuração de VLAN
Configuração de VLAN

Configuração de VLAN

Variações de VLAN em switches Catalyst

A criação de VLANs, como a maioria dos outros aspectos da rede, é uma questão de inserir os comandos apropriados. Este tópico detalha como configurar e verificar diferentes tipos de VLANs.

Diferentes switches Cisco Catalyst oferecem suporte a vários números de VLANs. O número de VLANs com suporte é grande o suficiente para acomodar as necessidades da maioria das organizações. Por exemplo, os switches da série Catalyst 2960 e 3650 suportam mais de 4.000 VLANs. As VLANs de intervalo normal nesses switches são numeradas de 1 a 1.005 e as VLANs de intervalo estendido são numeradas de 1.006 a 4.094. A figura ilustra as VLANs padrão em um switch Catalyst 2960 executando o Cisco IOS Release 15.x.

Switch# show vlan brief

VLAN Name Status Ports
---- ----------------- ------- --------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gi0/1, Gi0/2
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLANs de alcance normal

A seguir estão as características das VLANs de faixa normal:

  • Eles são usados ​​em todas as redes corporativas e de pequenas e médias empresas.
  • Eles são identificados por um ID de VLAN entre 1 e 1005.
  • Os IDs 1002 a 1005 são reservados para tecnologias de rede legadas (ou seja, Token Ring e Interface de dados distribuída de fibra).
  • Os IDs 1 e 1002 a 1005 são criados automaticamente e não podem ser removidos.
  • As configurações são armazenadas na memória flash do switch em um arquivo de banco de dados VLAN chamado vlan.dat.
  • Quando configurado, o protocolo de entroncamento VLAN (VTP) ajuda a sincronizar o banco de dados VLAN entre os switches.

VLANs de alcance estendido

A seguir estão as características das VLANs de intervalo estendido:

  • Eles são usados ​​por provedores de serviços para atender a vários clientes e por empresas globais grandes o suficiente para precisar de IDs de VLAN de alcance estendido.
  • Eles são identificados por um ID de VLAN entre 1006 e 4094.
  • As configurações são salvas, por padrão, na configuração em execução.
  • Eles suportam menos recursos de VLAN do que VLANs de alcance normal.
  • Requer configuração de modo transparente de VTP para oferecer suporte a VLANs de intervalo estendido.

Nota: 4096 é o limite superior para o número de VLANs disponíveis nos switches Catalyst, porque há 12 bits no campo VLAN ID do cabeçalho IEEE 802.1Q.

Comandos de criação de VLAN

Ao configurar VLANs de faixa normal, os detalhes da configuração são armazenados na memória flash do switch em um arquivo chamado vlan.dat. A memória flash é persistente e não requer o comando copy running-config startup-config. No entanto, como outros detalhes são frequentemente configurados em um switch Cisco ao mesmo tempo em que as VLANs são criadas, é uma boa prática salvar as alterações de configuração em execução na configuração de inicialização.

A tabela exibe a sintaxe de comando do Cisco IOS usada para adicionar uma VLAN a um switch e dar-lhe um nome. Nomear cada VLAN é considerado uma prática recomendada na configuração do switch.

TarefaComando IOS
Entre no modo de configuração global.Switch# configure terminal
Crie uma VLAN com um número de ID válido.Switch(config)# vlan vlan-id
Especifique um nome exclusivo para identificar a VLAN.Switch(config-vlan)# name vlan-name
Retorne ao modo EXEC privilegiado.Switch(config-vlan)# end

Exemplo de criação de VLAN

Na topologia, o computador do aluno (PC2) ainda não foi associado a uma VLAN, mas possui um endereço IP 172.17.20.22, que pertence à VLAN 20.

Exemplo de criação de VLAN

O exemplo mostra como a VLAN do aluno (VLAN 20) está configurada no switch S1.

S1# configure terminal
S1(config)# vlan 20
S1(config-vlan)# name student
S1(config-vlan)# end

Nota: Além de inserir um único ID de VLAN, uma série de IDs de VLAN podem ser inseridos separados por vírgulas ou um intervalo de IDs de VLAN separados por hífens usando o comando vlan vlan-id. Por exemplo, inserir o comando de configuração global vlan 100,102,105-107 criaria VLANs 100, 102, 105, 106 e 107.

Comandos de atribuição de porta VLAN

Depois de criar uma VLAN, a próxima etapa é atribuir portas à VLAN.

A tabela exibe a sintaxe para definir uma porta como uma porta de acesso e atribuí-la a uma VLAN. O comando switchport mode access é opcional, mas altamente recomendado como uma prática recomendada de segurança. Com este comando, a interface muda para o modo de acesso permanente.

TarefaComando IOS
Entre no modo de configuração global.Switch# configure terminal
Entre no modo de configuração da interface.Switch(config)# interface interface-id
Defina a porta para o modo de acesso.Switch(config-if)# switchport mode access
Atribua a porta a uma VLAN.Switch(config-if)# switchport access vlan vlan-id
Retorne ao modo EXEC privilegiado.Switch(config-if)# end

Nota: Use o comando interface range para configurar simultaneamente várias interfaces.

Exemplo de atribuição de porta VLAN

Na figura, a porta F0 / 6 no switch S1 está configurada como uma porta de acesso e atribuída à VLAN 20. Qualquer dispositivo conectado a essa porta será associado à VLAN 20. Portanto, em nosso exemplo, PC2 está na VLAN 20.

Exemplo de atribuição de porta VLAN

O exemplo mostra a configuração de S1 para atribuir F0 / 6 à VLAN 20.

S1# configure terminal
S1(config)# interface fa0/6
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 20
S1(config-if)# end

As VLANs são configuradas na porta do switch e não no dispositivo final. O PC2 está configurado com um endereço IPv4 e uma máscara de sub-rede associada à VLAN, que é configurada na porta do switch. Neste exemplo, é a VLAN 20. Quando a VLAN 20 é configurada em outros switches, o administrador da rede deve configurar os outros computadores dos alunos para estarem na mesma sub-rede que o PC2 (172.17.20.0/24).

VLANs de dados e voz

Uma porta de acesso pode pertencer a apenas uma VLAN de dados por vez. No entanto, uma porta também pode ser associada a uma VLAN de voz. Por exemplo, uma porta conectada a um telefone IP e um dispositivo final seriam associados a duas VLANs: uma para voz e outra para dados.

Considere a topologia na figura. O PC5 é conectado ao telefone Cisco IP, que por sua vez é conectado à interface FastEthernet 0/18 no S3. Para implementar esta configuração, uma VLAN de dados e uma VLAN de voz são criadas.

VLANs de dados e voz

Exemplo de VLAN de dados e voz

Use o comando de configuração da interface switchport voice vlan vlan-id para atribuir uma VLAN de voz a uma porta.

As LANs que oferecem suporte ao tráfego de voz normalmente também têm qualidade de serviço (QoS) habilitada. O tráfego de voz deve ser rotulado como confiável assim que entrar na rede. Use a confiança mls qos [cos | dispositivo cisco-phone | dscp | ip-precedence] interface configuration comando para definir o estado confiável de uma interface e para indicar quais campos do pacote são usados para classificar o tráfego.

A configuração no exemplo cria as duas VLANs (ou seja, VLAN 20 e VLAN 150) e, em seguida, atribui a interface F0 / 18 de S3 como uma porta de switch na VLAN 20. Também atribui tráfego de voz à VLAN 150 e permite a classificação de QoS com base no classe de serviço (CoS) atribuída pelo telefone IP.

S3(config)# vlan 20
S3(config-vlan)# name student
S3(config-vlan)# vlan 150
S3(config-vlan)# name VOICE
S3(config-vlan)# exit
S3(config)# interface fa0/18
S3(config-if)# switchport mode access
S3(config-if)# switchport access vlan 20
S3(config-if)# mls qos trust cos
S3(config-if)# switchport voice vlan 150
S3(config-if)# end
S3#

Nota: A implementação de QoS está além do escopo deste curso.

O comando switchport access vlan força a criação de uma VLAN se ela ainda não existir no switch. Por exemplo, a VLAN 30 não está presente na saída show vlan brief do switch. Se o comando switchport access vlan 30 for inserido em qualquer interface sem configuração anterior, o switch exibirá o seguinte:

% Access VLAN does not exist. Creating vlan 30

Verifique as informações de VLAN

Depois que uma VLAN é configurada, as configurações de VLAN podem ser validadas usando os comandos show do Cisco IOS.

O comando show vlan exibe uma lista de todas as VLANs configuradas. O comando show vlan também pode ser usado com opções. A sintaxe completa é show vlan [brief | id vlan-id | nome nome-vlan | summary].

A tabela descreve as opções do comando show vlan.

TarefaOpção de Comando
Exibe o nome da VLAN, o status e suas portas, uma VLAN por linha.brief
Exibir informações sobre o número de ID de VLAN identificado. Para vlan-id, o intervalo é de 1 a 4094.id vlan-id
Exibir informações sobre o nome de VLAN identificado. O vlan-name é uma string ASCII de 1 a 32 caracteres.name vlan-name
Exibir informações de resumo da VLAN.summary

O comando show vlan summary exibe a contagem de todas as VLANs configuradas.

S1# show vlan summary
Number of existing VLANs              : 7
Number of existing VTP VLANs          : 7
Number of existing extended VLANS     : 0

Outros comandos úteis são show interfaces interface-id switchport e o comando show interfaces vlan vlan-id. Por exemplo, o comando show interfaces fa0 / 18 switchport pode ser usado para confirmar se a porta FastEthernet 0/18 foi atribuída corretamente às VLANs de dados e voz.

S1# show interfaces fa0/18 switchport
Name: Fa0/18
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 20 (student) 
Trunking Native Mode VLAN: 1 (default)
Voice VLAN: 150
Administrative private-vlan host-association: none
(Output omitted)

Alterar associação de porta VLAN

Existem várias maneiras de alterar a associação da porta VLAN.

Se a porta de acesso do switch tiver sido atribuída incorretamente a uma VLAN, basta inserir novamente o comando de configuração da interface switchport access vlan vlan-id com o ID de VLAN correto. Por exemplo, suponha que Fa0 / 18 foi configurado incorretamente para estar na VLAN 1 padrão em vez da VLAN 20. Para alterar a porta para VLAN 20, simplesmente digite switchport access vlan 20.

Para alterar a associação de uma porta de volta à VLAN 1 padrão, use o comando no switchport access vlan interface configuration mode, conforme mostrado.

Na saída, por exemplo, Fa0 / 18 é configurado para estar na VLAN 1 padrão, conforme confirmado pelo comando show vlan brief.

S1(config)# interface fa0/18
S1(config-if)# no switchport access vlan
S1(config-if)# end
S1#
S1# show vlan brief
VLAN Name Status Ports
---- ------------------ --------- -------------------------------
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gi0/1, Gi0/2
20 student active 
1002 fddi-default act/unsup 
1003 token-ring-default act/unsup 
1004 fddinet-default act/unsup 
1005 trnet-default act/unsup

Observe que a VLAN 20 ainda está ativa, embora nenhuma porta esteja atribuída a ela.

A saída show interfaces f0/18 switchport também pode ser usada para verificar se a VLAN de acesso para a interface F0 / 18 foi redefinida para VLAN 1, conforme mostrado na saída.

S1# show interfaces fa0/18 switchport
Name: Fa0/18
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: negotiate
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)

Excluir VLANs

O comando do modo de configuração global no vlan vlan-id é usado para remover uma VLAN do arquivo switch vlan.dat.

Cuidado: Antes de excluir uma VLAN, reatribua todas as portas membro a uma VLAN diferente primeiro. Todas as portas que não são movidas para uma VLAN ativa não podem se comunicar com outros hosts depois que a VLAN é excluída e até que sejam atribuídas a uma VLAN ativa.

Todo o arquivo vlan.dat pode ser excluído usando o comando delete flash: vlan.dat privileged EXEC mode. A versão abreviada do comando (delete vlan.dat) pode ser usada se o arquivo vlan.dat não tiver sido movido de seu local padrão. Depois de emitir este comando e recarregar o switch, quaisquer VLANs configuradas anteriormente não estarão mais presentes. Isso efetivamente coloca o switch em sua condição padrão de fábrica com relação às configurações de VLAN.

Nota: Para restaurar um switch Catalyst à sua condição padrão de fábrica, desconecte todos os cabos, exceto o console e o cabo de alimentação do switch. Em seguida, digite o comando erase startup-config do modo EXEC privilegiado seguido pelo comando delete vlan.dat.

Verificador de sintaxe – configuração de VLAN

Nesta atividade do Verificador de sintaxe, você implementará e verificará uma configuração de VLAN para interfaces de switch com base nos requisitos especificados.

Conclua as seguintes etapas para criar uma VLAN de dados:

  • Entre no modo de configuração global.
  • Crie a VLAN 20.
  • Nomeie o aluno da VLAN.
  • Retorne ao modo EXEC privilegiado.
S1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S1(config)#vlan 20
S1(config-vlan)#name student
S1(config-vlan)#end
\*Mar 31, 08:55:14.5555: %SYS-5-CONFIG\_I: Configured from console by console

Exibe as informações resumidas da VLAN.

S1#show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gi0/1, Gi0/2
20   student                          active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

Conclua as seguintes etapas para criar uma VLAN de voz:

  • Entre no modo de configuração global.
  • Crie a VLAN 150.
  • Nomeie a VLAN VOICE.
  • Retornar ao modo de configuração global.
S1#configure terminal
S1(config)#vlan 150
S1(config-vlan)#name VOICE
S1(config-vlan)#exit

Conclua as etapas a seguir para atribuir as VLANs de dados e voz a uma porta:

  • Entre no modo de configuração da interface. Use fa0 / 18 como designação de interface.
  • Configure a porta como uma porta de acesso.
  • Atribua a VLAN 20 de dados à porta.
  • Habilite as configurações de QoS com o comando mls qos trust cos.
  • Atribua a VLAN 150 de voz à porta.
  • Retorne ao modo EXEC privilegiado.
S1(config)#interface fa0/18
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 20
S1(config-if)#mls qos trust cos
S1(config-if)#switchport voice vlan 150
S1(config-if)#end

Exibe as informações breves da vlan.

S1#show vlan brief
LAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/19, Fa0/20, Fa0/21
                                                Fa0/22, Fa0/23, Fa0/24, Gi0/1
                                                Gi0/2
20   student                          active    Fa0/18
150  VOICE                            active    Fa0/18
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

Conclua as etapas a seguir para excluir e verificar uma VLAN excluída em uma porta:

  • Entre no modo de configuração global.
  • Entre no modo de configuração da interface. Use fa0 / 18 como designação de interface.
  • Remova a VLAN de dados da porta.
  • Use a forma do do comando para exibir informações breves de VLAN.
S1#configure terminal
S1(config)#interface fa0/18
S1(config-if)#no switchport access vlan
S1(config-if)#do show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                                Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                                Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                                Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                                Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                                Gi0/1, Gi0/2
20   student                          active
150  VOICE                            active    Fa0/18
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

Conclua as etapas a seguir para atribuir a VLAN 20 a outra interface.

  • Entre no modo de configuração da interface. Use fa0 / 11 como designação de interface.
  • Atribua VLAN 20 à porta.
  • Retorne ao modo EXEC privilegiado.
S1(config-if)#interface fa0/11
S1(config-if)#switchport mode access
S1(config-if)#switchport access vlan 20
S1(config-if)#end

Exibe as informações resumidas da VLAN.

S1 # show vlan brief
Portas de status do nome da LAN
---- -------------------------------- --------- ----- --------------------------
1 Fa0 / 1 ativo padrão, Fa0 / 2, Fa0 / 3, Fa0 / 4
                                                 Fa0 / 5, Fa0 / 6, Fa0 / 7, Fa0 / 8
                                                 Fa0 / 9, Fa0 / 10, Fa0 / 12, Fa0 / 13
                                                 Fa0 / 14, Fa0 / 15, Fa0 / 16, Fa0 / 17
                                                 Fa0 / 19, Fa0 / 20, Fa0 / 21, Fa0 / 22
                                                 Fa0 / 23, Fa0 / 24, Gig0 / 1, Gig0 / 2
20 alunos ativos Fa0 / 11, Fa0 / 18
150 VOICE Fa0 / 18 ativo
1002 fddi-default act / unsup
1003 token-ring-default act / unsup
1004 fddinet-default act / unsup
1005 trnet-default act / unsup

Exibir as informações da VLAN especificamente para a VLAN do aluno.

S1#show vlan name student
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
20   student                          active    Fa0/11, Fa0/18
VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
20   enet  100020     1500  -      -      -        -    -        0      0

Exibir informações resumidas para VLANs

S1#show vlan summary
Number of existing VLANs : 7 
Number of existing VTP VLANs : 7 
Number of existing extended VLANS : 0

Exibe as informações da interface para VLAN 20.

S1#show interfaces vlan 20
Vlan20 is up, line protocol is up 
  Hardware is CPU Interface, address is 0007.ec74.61d3 (bia 0007.ec74.61d3) 
  MTU 1500 bytes, BW 100000 Kbit, DLY 1000000 usec, 
     reliability 255/255, txload 1/255, rxload 1/255 
  Encapsulation ARPA, loopback not set 
  ARP type: ARPA, ARP Timeout 04:00:00 
  Last input 21:40:21, output never, output hang never 
  Last clearing of "show interface" counters never 
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0 
  Queueing strategy: fifo 
  Output queue: 0/40 (size/max) 
  5 minute input rate 0 bits/sec, 0 packets/sec 
  5 minute output rate 0 bits/sec, 0 packets/sec 
     1682 packets input, 530955 bytes, 0 no buffer 
     Received 0 broadcasts (0 IP multicast) 
     0 runts, 0 giants, 0 throttles 
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored 
     563859 packets output, 0 bytes, 0 underruns 
     0 output errors, 23 interface resets 
     0 output buffer failures, 0 output buffers swapped out

Exibir as informações do switchport. Use fa0/11 para a designação da interface.

S1#show interface fa0/11 switchport
Name: Fa0/11 
Switchport: Enabled 
Administrative Mode: static access 
Operational Mode: down 
Administrative Trunking Encapsulation: dot1q 
Operational Trunking Encapsulation: native 
Negotiation of Trunking: Off 
Access Mode VLAN: 20 (Students) 
Trunking Native Mode VLAN: 1 (default) 
Voice VLAN: none
(output omitted)

Packet Tracer – Configuração de VLAN

Nesta atividade do Packet Tracer, você executará o seguinte:

  • Verifique a configuração de VLAN padrão
  • Configurar VLANs
  • Atribuir VLANs às portas
[button url=”https://www.ccna.network/wp-content/uploads/2021/03/3.3.12-pt.zip” target=”self” style=”default” background=”#2fa614″ color=”#FFFFFF” size=”3″ wide=”no” center=”yes” radius=”auto” icon=”” icon_color=”#FFFFFF” text_shadow=”none” desc=”” download=”” onclick=”” rel=”” title=”” id=”” class=””]BAIXE AQUI[/button]

Pronto para ir! Continue visitando nosso blog do curso de networking, confira todo o conteúdo do CCNA 3 aqui; e você encontrará mais ferramentas e conceitos que o tornarão um profissional de rede.

Aplicação CCNA Dump já disponívelApp Store