Resolver Problemas de Roteamento entre VLANs
Resolver Problemas de Roteamento entre VLANs

Resolver Problemas de Roteamento entre VLANs

Problemas comuns entre VLANs

A esta altura, você já sabe que, ao configurar e verificar, também deve ser capaz de solucionar problemas. Este tópico discute alguns problemas comuns de rede associados ao roteamento entre VLANs.

Existem vários motivos pelos quais uma configuração entre VAN pode não funcionar. Todos estão relacionados a problemas de conectividade. Primeiro, verifique a camada física para resolver quaisquer problemas em que um cabo possa ser conectado à porta errada. Se as conexões estiverem corretas, use a lista na tabela para outros motivos comuns pelos quais a conectividade entre VLANs pode falhar.

Tipo de problemaComo consertarComo verificar
VLANs ausentesCrie (ou recrie) a VLAN, se ela não existir. Certifique-se de que a porta do host esteja atribuída à VLAN correta.show vlan [brief] show interfaces switchport ping
Problemas da porta do tronco do switchCertifique-se de que os troncos estejam configurados corretamente. Certifique-se de que a porta é uma porta de tronco e está habilitada.show interfaces trunk show running-config
Problemas com a porta de acesso do switchAtribua a VLAN correta à porta de acesso. Certifique-se de que a porta é uma porta de acesso e está habilitada. O host está configurado incorretamente na sub-rede errada.show interfaces switchport show running-config interface ipconfig
Problemas de configuração do roteadorO endereço IPv4 da subinterface do roteador está configurado incorretamente. A subinterface do roteador está atribuída à ID da VLAN.show ip interface brief show interfaces

Solução de problemas de cenário de roteamento entre VLAN

Exemplos de alguns desses problemas de roteamento entre VLANs agora serão abordados com mais detalhes.

Essa topologia será usada para todos esses problemas.

Solução de problemas de exemplo de roteamento entre VLAN

As informações de endereçamento VLAN e IPv4 para R1 são mostradas na tabela.

Subinterfaces do roteador R1

SubinterfaceVLANEndereço de IP
G0/0/0.1010192.168.10.1/24
G0/0/0.2020192.168.20.1/24
G0/0/0.3099192.168.99.1/24

VLANs ausentes

Um problema de conectividade entre VLANs pode ser causado por uma VLAN ausente. A VLAN pode estar faltando se não tiver sido criada, excluída acidentalmente ou não for permitida no link de tronco.

Por exemplo, PC1 está atualmente conectado à VLAN 10, conforme mostrado na saída do comando show vlan brief.

S1# show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gi0/1, Gi0/2
10   LAN10                            active    Fa0/6
20   LAN20                            active
99   Management                       active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
S1#

Agora suponha que a VLAN 10 seja excluída acidentalmente, conforme mostrado na saída a seguir.

S1(config)# no vlan 10
S1(config)# do show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gi0/1, Gi0/2
20   LAN20                            active
99   Management                       active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
S1(config)#

Observe que a VLAN 10 agora está faltando na saída. Observe também que a porta Fa0 / 6 não foi reatribuída à VLAN padrão. A razão é porque, quando você exclui uma VLAN, todas as portas atribuídas a essa VLAN tornam-se inativas. Eles permanecem associados à VLAN (e, portanto, inativos) até que você os atribua a uma nova VLAN ou recrie a VLAN ausente.

Use o comando show interface interface-id switchport para verificar a associação da VLAN.

S1(config)# do show interface fa0/6 switchport
Name: Fa0/6
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 10 (Inactive)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
(Output omitted)

A recriação da VLAN ausente reatribuiria automaticamente os hosts a ela, conforme mostrado na saída a seguir.

S1(config)# vlan 10
S1(config-vlan)# do show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gi0/1, Gi0/2
20   LAN20                            active
99   Management                       active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
S1(config-vlan)#

Observe que a VLAN não foi criada conforme o esperado. O motivo é porque você deve sair do modo de subconfiguração de VLAN para criar a VLAN, conforme mostrado na saída a seguir.

S1(config-vlan)# exit
S1(config)# do show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gi0/1, Gi0/2
10   VLAN0010                         active    Fa0/6
20   LAN20                            active
99   Management                       active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
S1(config)#

Agora observe que a VLAN está incluída na lista e que o host conectado a Fa0 / 6 está na VLAN 10.

Problemas da porta do tronco do switch

Outro problema para o roteamento entre VLANs inclui portas de switch configuradas incorretamente. Em uma solução inter-VLAN legada, isso pode ser causado quando a porta do roteador de conexão não está atribuída à VLAN correta.

No entanto, com uma solução de roteador fixo, a causa mais comum é uma porta de tronco mal configurada.

Por exemplo, suponha que PC1 fosse capaz de se conectar a hosts em outras VLANs até recentemente. Uma rápida olhada nos registros de manutenção revelou que o switch S1 Layer 2 foi acessado recentemente para manutenção de rotina. Portanto, você suspeita que o problema pode estar relacionado a essa opção.

Solução de problemas de exemplo de roteamento entre VLAN

Em S1, verifique se a porta que se conecta a R1 (ou seja, F0/5) está configurada corretamente como um link de tronco usando o comando show interfaces trunk, conforme mostrado.

S1# show interfaces trunk
Port        Mode             Encapsulation  Status        Native vlan
Fa0/1       on               802.1q         trunking      1
Port        Vlans allowed on trunk
Fa0/1       1-4094
Port        Vlans allowed and active in management domain
Fa0/1       1,10,20,99
Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,10,20,99
S1#

A porta Fa0/5 conectada a R1 está misteriosamente ausente da saída. Verifique a configuração da interface usando o comando show running-config interface fa0/5, conforme mostrado.

S1# show running-config interface fa0/5
Building configuration...
Current configuration : 96 bytes
!
interface FastEthernet0/5
 description Trunk link to R1
 switchport mode trunk
 shutdown
end
S1#

Como você pode ver, a porta foi desligada acidentalmente. Para corrigir o problema, reative a porta e verifique o status do entroncamento, conforme mostrado na saída.

S1(config)# interface fa0/5
S1(config-if)# no shut
S1(config-if)#
*Mar  1 04:46:44.153: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to up
S1(config-if)#
*Mar  1 04:46:47.962: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed state to up
S1(config-if)# do show interface trunk
Port        Mode             Encapsulation  Status        Native vlan
Fa0/1       on               802.1q         trunking      1
Fa0/5       on               802.1q         trunking      1
Port        Vlans allowed on trunk
Fa0/1       1-4094
Fa0/5       1-4094
Port        Vlans allowed and active in management domain
Fa0/1       1,10,20,99
Fa0/5       1,10,20,99
Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,10,20,99
Fa0/1       1,10,20,99
S1(config-if)#

Para reduzir o risco de falha no link entre switches, interrompendo o roteamento entre VLANs, links redundantes e caminhos alternativos devem fazer parte do projeto da rede.

Problemas com a porta de acesso do switch

Quando houver suspeita de um problema com a configuração da porta de acesso do switch, use os comandos de verificação para examinar a configuração e identificar o problema.

Suponha que PC1 tenha o endereço IPv4 e o gateway padrão corretos, mas não seja capaz de executar ping em seu próprio gateway padrão. PC1 deve estar conectado a uma porta VLAN 10.

Solução de problemas de exemplo de roteamento entre VLAN

Verifique a configuração da porta em S1 usando o comando show interfaces interface-id switchport.

S1# show interface fa0/6 switchport
Name: Fa0/6
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none

A porta Fa0 / 6 foi configurada como uma porta de acesso conforme indicado por “acesso estático”. No entanto, parece que não foi configurado para estar na VLAN 10. Verifique a configuração da interface.

S1# show running-config interface fa0/6
Building configuration...
Current configuration : 87 bytes
!
interface FastEthernet0/6
 description PC-A access port
 switchport mode access
end
S1#

Atribua a porta Fa0 / 6 à VLAN 10 e verifique a atribuição da porta.

S1# configure terminal
S1(config)# interface fa0/6
S1(config-if)# switchport access vlan 10
S1(config-if)# 
S1(config-if)# do show interface fa0/6 switchport
Name: Fa0/6
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 10 (VLAN0010)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
(Output omitted)

O PC1 agora pode se comunicar com hosts em outras VLANs.

Problemas de configuração do roteador

Os problemas de configuração do roteador fixo geralmente estão relacionados a configurações incorretas de subinterface. Por exemplo, um endereço IP incorreto foi configurado ou o ID de VLAN incorreto foi atribuído à subinterface.

Por exemplo, R1 deve fornecer roteamento entre VLANs para usuários nas VLANs 10, 20 e 99. No entanto, os usuários na VLAN 10 não podem acessar nenhuma outra VLAN.

Solução de problemas de exemplo de roteamento entre VLAN

Você verificou o link do tronco da central e tudo parece estar em ordem. Verifique o status da subinterface usando o comando show ip interface brief.

R1# show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0/0   unassigned      YES unset  administratively down down
GigabitEthernet0/0/1   unassigned      YES unset  up                    up
Gi0/0/1.10             192.168.10.1    YES manual up                    up
Gi0/0/1.20             192.168.20.1    YES manual up                    up
Gi0/0/1.99             192.168.99.1    YES manual up                    up
Serial0/1/0            unassigned      YES unset  administratively down down
Serial0/1/1            unassigned      YES unset  administratively down down
R1#

As subinterfaces foram atribuídas aos endereços IPv4 corretos e estão operacionais.

Verifique em quais VLANs cada uma das subinterfaces está. Para fazer isso, o comando show interfaces é útil, mas gera uma grande quantidade de saída adicional desnecessária. A saída do comando pode ser reduzida usando filtros de comando IOS, conforme mostrado na saída.

R1# show interfaces | include Gig|802.1Q
GigabitEthernet0/0/0 is administratively down, line protocol is down
GigabitEthernet0/0/1 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
GigabitEthernet0/0/1.10 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  100.
GigabitEthernet0/0/1.20 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  20.
GigabitEthernet0/0/1.99 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  99.
R1#

O símbolo de barra vertical (|) junto com algumas palavras-chave selecionadas é um método útil para ajudar a filtrar a saída do comando. Neste exemplo, a palavra-chave include foi usada para identificar que apenas as linhas contendo as letras “Gig” ou “802.1Q” serão exibidas. Devido à maneira como a saída da show interface da exibição é listada naturalmente, o uso desses filtros produz uma lista condensada de interfaces e suas VLANs atribuídas.

Observe que a interface G0 / 0 / 1.10 foi atribuída incorretamente à VLAN 100 em vez da VLAN 10. Isso é confirmado observando a configuração da subinterface R1 GigabitEthernet 0/0 / 1.10, conforme mostrado.

R1# show running-config interface g0/0/1.10
Building configuration...
Current configuration : 146 bytes
!
interface GigabitEthernet0/0/1.10
 description Default Gateway for VLAN 10
 encapsulation dot1Q 100
 ip address 192.168.10.1 255.255.255.0
end
R1#

Para corrigir esse problema, configure a subinterface G0 / 0 / 1.10 para estar na VLAN correta usando o comando de modo de configuração de subinterface dot1q 10 de encapsulamento.

R1# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# interface gigabitEthernet 0/0/1.10
R1(config-subif)# encapsulation dot1Q 10
R1(config-subif)# end
R1#
R1# show interfaces | include Gig|802.1Q
GigabitEthernet0/0/0 is administratively down, line protocol is down
GigabitEthernet0/0/1 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
GigabitEthernet0/0/1.10 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  10.
GigabitEthernet0/0/1.20 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  20.
GigabitEthernet0/0/1.99 is up, line protocol is up
R1#

Quando a subinterface foi atribuída à VLAN correta, ela pode ser acessada por dispositivos nessa VLAN e o roteador pode executar o roteamento entre VLANs.

Com a verificação, os problemas de configuração do roteador são resolvidos rapidamente, permitindo que o roteamento entre VLANs funcione corretamente.

Packet Tracer – Solução de problemas de roteamento entre VLAN

Nesta atividade do Packet Tracer, você completará os seguintes objetivos:

  • Parte 1: Localize problemas de rede
  • Parte 2: Implementar a Solução
  • Parte 3: Verifique a conectividade da rede
[button url=”https://www.ccna.network/wp-content/uploads/2021/03/4.4.8-pt.zip” target=”self” style=”default” background=”#2fa614″ color=”#FFFFFF” size=”3″ wide=”no” center=”yes” radius=”auto” icon=”” icon_color=”#FFFFFF” text_shadow=”none” desc=”” download=”” onclick=”” rel=”” title=”” id=”” class=””]BAIXE AQUI[/button]

Laboratório – Solução de problemas de roteamento entre VLAN

Neste laboratório, você concluirá os seguintes objetivos:

  • Parte 1: Crie a rede e carregue as configurações do dispositivo
  • Parte 2: solucionar problemas de configuração de roteamento entre VLANs
  • Parte 3: Verifique a configuração de VLAN, atribuição de porta e entroncamento
  • Parte 4: Teste de conectividade da camada 3
[button url=”https://www.ccna.network/wp-content/uploads/2021/03/4.4.9-lab.zip” target=”self” style=”default” background=”#2fa614″ color=”#FFFFFF” size=”3″ wide=”no” center=”yes” radius=”auto” icon=”” icon_color=”#FFFFFF” text_shadow=”none” desc=”” download=”” onclick=”” rel=”” title=”” id=”” class=””]BAIXE AQUI[/button]

Pronto para ir! Continue visitando nosso blog do curso de networking, confira todo o conteúdo do CCNA 3 aqui; e você encontrará mais ferramentas e conceitos que o tornarão um profissional de rede.

Aplicação CCNA Dump já disponívelApp Store