Roteamento entre VLANs usando switches da Camada 3
Roteamento entre VLANs usando switches da Camada 3

Roteamento entre VLANs usando switches da Camada 3

Roteamento Inter-VLAN de switch de camada 3

Redes corporativas modernas raramente usam roteador fixo porque ele não é facilmente escalável para atender aos requisitos. Nessas redes muito grandes, os administradores de rede usam switches da Camada 3 para configurar o roteamento entre VLANs.

O roteamento entre VLANs usando o método router-on-a-stick é simples de implementar para uma organização de pequeno a médio porte. No entanto, uma grande empresa requer um método mais rápido e escalável para fornecer roteamento entre VLANs.

LANs de campus corporativos usam switches da Camada 3 para fornecer roteamento entre VLANs. Os switches da Camada 3 usam comutação baseada em hardware para obter taxas de processamento de pacotes mais altas do que os roteadores. Os switches da camada 3 também são comumente implementados em wiring closets da camada de distribuição corporativa.

Os recursos de um switch de Camada 3 incluem a capacidade de fazer o seguinte:

  • Faça o roteamento de uma VLAN para outra usando várias interfaces virtuais comutadas (SVIs).
  • Converta uma porta de switch da Camada 2 em uma interface da Camada 3 (ou seja, uma porta roteada). Uma porta roteada é semelhante a uma interface física em um roteador Cisco IOS.

Para fornecer roteamento entre VLANs, os switches da Camada 3 usam SVIs. Os SVIs são configurados usando o mesmo comando interface vlan vlan-id usado para criar o SVI de gerenciamento em um switch da Camada 2. Um SVI da camada 3 deve ser criado para cada uma das VLANs roteáveis.

Cenário de mudança de camada 3

Na figura, o switch da Camada 3, D1, está conectado a dois hosts em VLANs diferentes. PC1 está na VLAN 10 e PC2 está na VLAN 20, conforme mostrado. O switch da Camada 3 fornecerá serviços de roteamento entre VLANs para os dois hosts.

Cenário de mudança de camada 3

A tabela mostra os endereços IP para cada VLAN.

Endereços IP D1 VLAN

Interface VLANEndereço de IP
10192.168.10.1/24
20192.168.20.1/24

Configuração de switch de camada 3

Conclua as seguintes etapas para configurar S1 com VLANs e entroncamento:

  • Etapa 1. Crie as VLANs.
  • Etapa 2. Crie as interfaces SVI VLAN.
  • Etapa 3. Configurar portas de acesso.
  • Etapa 4. Habilite o roteamento IP.

Clique em cada botão para obter detalhes da etapa de configuração.

Primeiro, crie as duas VLANs conforme mostrado na saída.

D1(config)# vlan 10
D1(config-vlan)# name LAN10
D1(config-vlan)# vlan 20
D1(config-vlan)# name LAN20
D1(config-vlan)# exit
D1(config)#

Configure o SVI para as VLANs 10 e 20. Os endereços IP configurados servirão como gateways padrão para os hosts nas respectivas VLANs. Observe as mensagens informativas que mostram o protocolo de linha em ambos os SVIs alterado para up.

D1(config)# interface vlan 10
D1(config-if)# description Default Gateway SVI for 192.168.10.0/24
D1(config-if)# ip add 192.168.10.1 255.255.255.0
D1(config-if)# no shut
D1(config-if)# exit
D1(config)#
D1(config)# int vlan 20
D1(config-if)# description Default Gateway SVI for 192.168.20.0/24
D1(config-if)# ip add 192.168.20.1 255.255.255.0
D1(config-if)# no shut
D1(config-if)# exit
D1(config)#
*Sep 17 13:52:16.053: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
*Sep 17 13:52:16.160: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

Em seguida, configure as portas de acesso conectadas aos hosts e atribua-as às suas respectivas VLANs.

D1(config)# interface GigabitEthernet1/0/6
D1(config-if)# description Access port to PC1
D1(config-if)# switchport mode access
D1(config-if)# switchport access vlan 10
D1(config-if)# exit
D1(config)#
D1(config)# interface GigabitEthernet1/0/18
D1(config-if)# description Access port to PC2
D1(config-if)# switchport mode access
D1(config-if)# switchport access vlan 20
D1(config-if)# exit

Finalmente, habilite o roteamento IPv4 com o comando ip routing global configuration para permitir que o tráfego seja trocado entre as VLANs 10 e 20. Este comando deve ser configurado para habilitar o roteamento entre VANs em um switch da Camada 3 para IPv4.

D1(config)# ip routing
D1(config)#

Verificação de roteamento inter-VLAN de switch de camada 3

O roteamento entre VLANs usando um switch da Camada 3 é mais simples de configurar do que o método de roteador fixo. Após a conclusão da configuração, ela pode ser verificada testando a conectividade entre os hosts.

De um host, verifique a conectividade com um host em outra VLAN usando o comando ping. É uma boa ideia verificar primeiro a configuração IP do host atual usando o comando ipconfig host do Windows. A saída confirma o endereço IPv4 e o gateway padrão de PC1.

C:\Users\PC1> ipconfig
Windows IP Configuration
Ethernet adapter Ethernet0:
  Connection-specific DNS Suffix . :
  Link-local IPv6 Address          : fe80::5c43:ee7c:2959:da68%6
  IPv4 Address                     : 192.168.10.10
  Subnet Mask                      : 255.255.255.0
  Default Gateway                  : 192.168.10.1
C:\Users\PC1>

Em seguida, verifique a conectividade com o PC2 usando o comando ping Windows host, conforme mostrado na saída. A saída do ping confirma com sucesso que o roteamento entre VLAN está operando.

C:\Users\PC1> ping 192.168.20.10
Pinging 192.168.20.10 with 32 bytes of data:
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Ping statistics for 192.168.20.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
C:\Users\PC1>

Roteamento em um switch de camada 3

Se as VLANs devem ser alcançadas por outros dispositivos da Camada 3, elas devem ser anunciadas usando roteamento estático ou dinâmico. Para habilitar o roteamento em um switch da Camada 3, uma porta roteada deve ser configurada.

Uma porta roteada é criada em um switch da Camada 3 desativando o recurso switchport em uma porta da Camada 2 que está conectada a outro dispositivo da Camada 3. Especificamente, configurar o comando no switchport interface configuration em uma porta da Camada 2 o converte em uma interface da Camada 3. Em seguida, a interface pode ser configurada com uma configuração IPv4 para se conectar a um roteador ou outro switch de Camada 3.

Cenário de roteamento em um switch de camada 3

Na figura, o switch D1 Layer 3 configurado anteriormente está agora conectado a R1. R1 e D1 estão em um domínio de protocolo de roteamento OSPF (Open Shortest Path First). Suponha que a inter-VLAN tenha sido implementada com sucesso em D1. A interface G0 / 0/1 de R1 também foi configurada e habilitada. Além disso, R1 está usando o OSPF para anunciar suas duas redes, 10.10.10.0/24 e 10.20.20.0/24.

Nota: A configuração de roteamento OSPF é abordada em outro curso. Neste módulo, os comandos de configuração do OSPF serão fornecidos a você em todas as atividades e avaliações. Não é necessário que você entenda a configuração para habilitar o roteamento OSPF no switch da Camada 3.

Configuração de roteamento em um switch de camada 3

Conclua as seguintes etapas para configurar D1 para rotear com R1:

Etapa 1. Configurar a porta roteada.
Etapa 2. Habilite o roteamento.
Etapa 3. Configurar o roteamento.
Etapa 4. Verificar o roteamento.
Etapa 5. Verifique a conectividade.

Clique em cada botão para obter detalhes da etapa de configuração.

Configure G1 / 0/1 para ser uma porta roteada, atribua a ela um endereço IPv4 e ative-a.

D1(config)# interface GigabitEthernet1/0/1
D1(config-if)# description routed Port Link to R1
D1(config-if)# no switchport
D1(config-if)# ip address 10.10.10.2 255.255.255.0
D1(config-if)# no shut
D1(config-if)# exit
D1(config)#

Certifique-se de que o roteamento IPv4 esteja habilitado com o comando ip routing global configuration.

D1(config)# ip routing
D1(config)#

Configure o protocolo de roteamento OSPF para anunciar as redes VLAN 10 e VLAN 20, junto com a rede que está conectada a R1. Observe a mensagem informando que uma adjacência foi estabelecida com R1.

D1(config)# router ospf 10
D1(config-router)# network 192.168.10.0 0.0.0.255 area 0
D1(config-router)# network 192.168.20.0 0.0.0.255 area 0
D1(config-router)# network 10.10.10.0 0.0.0.3 area 0
D1(config-router)# ^Z
D1#
*Sep 17 13:52:51.163: %OSPF-5-ADJCHG: Process 10, Nbr 10.20.20.1 on GigabitEthernet1/0/1 from LOADING to FULL, Loading Done
D1#

Verifique a tabela de roteamento em D1. Observe que D1 agora tem uma rota para a rede 10.20.20.0/24.

D1# show ip route | begin Gateway
Gateway of last resort is not set
      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C        10.10.10.0/30 is directly connected, GigabitEthernet1/0/1
L        10.10.10.2/32 is directly connected, GigabitEthernet1/0/1
O        10.20.20.0/24 [110/2] via 10.10.10.1, 00:00:06, GigabitEthernet1/0/1
      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.0/24 is directly connected, Vlan10
L        192.168.10.1/32 is directly connected, Vlan10
      192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.20.0/24 is directly connected, Vlan20
L        192.168.20.1/32 is directly connected, Vlan20
D1#

Neste momento, PC1 e PC2 podem executar ping no servidor conectado a R1.

C:\Users\PC1> ping 10.20.20.254
Pinging 10.20.20.254 with 32 bytes of data: 
Request timed out.
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Ping statistics for 10.20.20.254:
    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss).
Approximate round trip times in milli-seconds: 
    Minimum = 1ms, Maximum = 2ms, Average = 1ms 
C:\Users\PC1>
!==================================================
C:\Users\PC2> ping 10.20.20.254
Pinging 10.20.20.254 with 32 bytes of data: 
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Ping statistics for 10.20.20.254:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss).
Approximate round trip times in milli-seconds: 
    Minimum = 1ms, Maximum = 2ms, Average = 1ms
C:\Users\PC2>

Packet Tracer – Configurar Switching da Camada 3 e Roteamento Inter-VLAN

Nesta atividade, você configurará a comutação da Camada 3 e o roteamento entre VLANs em um switch Cisco 3560.

[button url=”https://www.ccna.network/wp-content/uploads/2021/03/4.3.8-pt.zip” target=”self” style=”default” background=”#2fa614″ color=”#FFFFFF” size=”3″ wide=”no” center=”yes” radius=”auto” icon=”” icon_color=”#FFFFFF” text_shadow=”none” desc=”” download=”” onclick=”” rel=”” title=”” id=”” class=””]BAIXE AQUI[/button]

Pronto para ir! Continue visitando nosso blog do curso de networking, confira todo o conteúdo do CCNA 3 aqui; e você encontrará mais ferramentas e conceitos que o tornarão um profissional de rede.

Aplicação CCNA Dump já disponívelApp Store