Verificar e Solucionar Problemas do EtherChannel
Verificar e Solucionar Problemas do EtherChannel

Verificar e Solucionar Problemas do EtherChannel

Verificar EtherChannel

Como sempre, ao configurar dispositivos em sua rede, você deve verificar sua configuração. Se houver problemas, você também precisará solucioná-los e corrigi-los. Este tópico fornece os comandos para verificar, bem como alguns problemas comuns de rede EtherChannel e suas soluções.

Os exemplos de comandos de verificação usarão a topologia mostrada na figura.

Verificar Exemplo EtherChannel

Existem vários comandos para verificar uma configuração EtherChannel. Clique em cada botão para obter uma explicação e saída de comando.

O comando show interfaces port-channel exibe o status geral da interface do canal de porta. Na figura, a interface do Canal 1 da porta está ativa.

S1# show interfaces port-channel 1
Port-channel1 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is c07b.bcc4.a981 (bia c07b.bcc4.a981)
  MTU 1500 bytes, BW 200000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
(output omitted)

Quando várias interfaces de canal de porta são configuradas no mesmo dispositivo, use o comando show etherchannel summary para exibir uma linha de informações por canal de porta. Na saída, o switch tem um EtherChannel configurado; o grupo 1 usa LACP.

O pacote de interface consiste nas interfaces FastEthernet0 / 1 e FastEthernet0 / 2. O grupo é um EtherChannel de Camada 2 e está em uso, conforme indicado pelas letras SU próximas ao número do canal da porta.

S1# show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator
        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
        A - formed by Auto LAG
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Fa0/1(P)    Fa0/2(P)

Use o comando show etherchannel port-channel para exibir informações sobre uma interface de canal de porta específica, conforme mostrado na saída. No exemplo, a interface do Canal 1 da porta consiste em duas interfaces físicas, FastEthernet0 / 1 e FastEthernet0 / 2. Ele usa o LACP no modo ativo. Ele está conectado corretamente a outro switch com uma configuração compatível, e é por isso que se diz que o canal da porta está em uso.

S1# show etherchannel port-channel
                Channel-group listing:
                ----------------------
Group: 1
----------
                Port-channels in the group:
                ---------------------------
Port-channel: Po1    (Primary Aggregator)
------------
Age of the Port-channel   = 0d:01h:02m:10s
Logical slot/port   = 2/1          Number of ports = 2
HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   LACP
Port security       = Disabled
Load share deferral = Disabled
Ports in the Port-channel:
Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Fa0/1    Active             0
  0     00     Fa0/2    Active             0
Time since last port bundled:    0d:00h:09m:30s    Fa0/2

Em qualquer membro da interface física de um pacote EtherChannel, o comando show interfaces etherchannel pode fornecer informações sobre a função da interface no EtherChannel, conforme mostrado na saída. A interface FastEthernet0 / 1 faz parte do pacote EtherChannel 1. O protocolo para este EtherChannel é LACP.

S1# show interfaces f0/1 etherchannel
Port state    = Up Mstr Assoc In-Bndl
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP
Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.
Local information:
                            LACP port     Admin     Oper    Port       
Port      Flags   State     Priority      Key       Number  State
Fa0/1     SA      bndl      32768         0x1       0x1     0x102       0x3D
Partner's information:
                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Fa0/1     SA      32768     c025.5cd7.ef00  12s    0x0    0x1    0x102   0x3Dof the port in the current state: 0d:00h:11m:51sllowed vlan 1,2,20

Problemas comuns com configurações EtherChannel

Todas as interfaces em um EtherChannel devem ter a mesma configuração de velocidade e modo duplex, VLANs nativas e permitidas em troncos e VLAN de acesso em portas de acesso. Garantir essas configurações reduzirá significativamente os problemas de rede relacionados ao EtherChannel. Os problemas comuns do EtherChannel incluem o seguinte:

  • As portas atribuídas no EtherChannel não fazem parte da mesma VLAN ou não estão configuradas como troncos. As portas com diferentes VLANs nativas não podem formar um EtherChannel.
  • O entroncamento foi configurado em algumas das portas que compõem o EtherChannel, mas não em todas. Não é recomendado que você configure o modo de entroncamento em portas individuais que compõem o EtherChannel. Ao configurar um tronco em um EtherChannel, verifique o modo de entroncamento no EtherChannel.
  • Se o intervalo permitido de VLANs não for o mesmo, as portas não formam um EtherChannel mesmo quando o PAgP está definido para o modo automático ou desejável.
  • As opções de negociação dinâmica para PAgP e LACP não são configuradas de forma compatível em ambas as extremidades do EtherChannel.

Nota: É fácil confundir PAgP ou LACP com DTP, porque eles são todos protocolos usados ​​para automatizar o comportamento em links de tronco. PAgP e LACP são usados ​​para agregação de link (EtherChannel). O DTP é usado para automatizar a criação de links de tronco. Quando um tronco EtherChannel é configurado, normalmente o EtherChannel (PAgP ou LACP) é configurado primeiro e depois o DTP.

Exemplo de solução de problemas de EtherChannel

Na figura, as interfaces F0 / 1 e F0 / 2 nas chaves S1 e S2 estão conectadas com um EtherChannel. No entanto, o EtherChannel não está operacional.

Verificar Exemplo EtherChannel

Clique em cada botão para obter as etapas para solucionar problemas do EtherChannel.

A saída do comando show etherchannel summary indica que o EtherChannel está inativo.

S1# show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator
        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
        A - formed by Auto LAG
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         -      Fa0/1(D)    Fa0/2(D)

No show run | começar a saída do canal de porta da interface, uma saída mais detalhada indica que existem modos PAgP incompatíveis configurados em S1 e S2.

S1# show run | begin interface port-channel
interface Port-channel1
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
!
interface FastEthernet0/1
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/2
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
 channel-group 1 mode on
!======================================
S2# show run | begin interface port-channel
interface Port-channel1
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
!
interface FastEthernet0/1
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/2
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
 channel-group 1 mode desirable

Para corrigir o problema, o modo PAgP no EtherChannel é alterado para desejável.

Nota: EtherChannel e STP devem interoperar. Por esse motivo, a ordem em que os comandos relacionados ao EtherChannel são inseridos é importante, e é por isso que você vê a interface Port-Channel 1 removida e então adicionada novamente com o comando channel-group, em vez de diretamente alterado. Se alguém tentar alterar a configuração diretamente, os erros de STP farão com que as portas associadas entrem no estado de bloqueio ou desativado por erro.

S1(config)# no interface port-channel 1
S1(config)# interface range fa0/1 - 2
S1(config-if-range)# channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1
S1(config-if-range)# no shutdown
S1(config-if-range)# exit
S1(config)# interface range fa0/1 - 2
S1(config-if-range)# channel-group 1 mode desirable
S1(config-if-range)# no shutdown
S1(config-if-range)# interface port-channel 1
S1(config-if)# switchport mode trunk
S1(config-if)# end
S1#

O EtherChannel está agora ativo conforme verificado pela saída do comando show etherchannel summary.

S1# show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator
        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
        A - formed by Auto LAG
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Fa0/1(P)    Fa0/2(P)

Packet Tracer – solucionar problemas do EtherChannel

Quatro switches foram configurados recentemente por um técnico júnior. Os usuários estão reclamando que a rede está lenta e gostaria que você investigasse.

[button url=”https://www.ccna.network/wp-content/uploads/2021/03/6.3.4-pt.zip” target=”self” style=”default” background=”#2fa614″ color=”#FFFFFF” size=”3″ wide=”no” center=”yes” radius=”auto” icon=”” icon_color=”#FFFFFF” text_shadow=”none” desc=”” download=”” onclick=”” rel=”” title=”” id=”” class=””]BAIXE AQUI[/button]

Pronto para ir! Continue visitando nosso blog do curso de networking, confira todo o conteúdo do CCNA 3 aqui; e você encontrará mais ferramentas e conceitos que o tornarão um profissional de rede.

CCNA: Introdução às RedesCurso